IN_Santri

Inspirasi Santri

PROYEK JARINGAN

KONFIGURASI DASAR MIKROTIK

  1. Interface : Beri nama Interface di mikrotik. Interface sesuai dengan port lan di mikrotik. Umumnya Port lan 1 sebagai sumber internet.
  2. System => Identity : Memberi nama Mikrotik
  3. System => User : Buat user baru dengan full admin dan hapus user Admin default! (berguna untuk mengamankan router
  4. IP => DHCP Client : Konfigurasi supaya mikrotik mendapatan IP dari Modem, yaitu untuk Port LAN 1.
    • Tombol PLUS
    • Interface : ISP
    • Checklist semua
    • Add Default Routes : YES
    • Apabila ingin menggunakan ip static, maka jangan gunakan cara ini.
  5. IP => DNS : Menambahkan DNS. Kita memakai DNS standard.
    • 8.8.8.8
    • 8.8.4.4
    • Checklist Allow Remote Requests
  6. IP => FIREWALL => NAT : Penerus internet dari ISP port LAN 1 menuju ke port lan yang lain.
    • Tombol PLUS
    • General => Chain : srcnat
    • Out. Interface = 1. ISP
    • Action => Action : Masquerade
    • lakukan di semua port lan supaya bisa saling akses beda segmen ip
  7. IP => Addresses : Menentukan IP pada port LAN lain
    • Tombol PLUS
    • Interface : (pilih interface lan )
    • Address : 10.10.10.1/24
    • OK
    • Tombol PLUS
    • Interface : 1. ISP
    • Address : 192.168.1.1/24
    • OK
    • (apabila memilih setting static pada port isp)
  8. IP => DHCP Server => DHCP => DHCP Setup :
    • Interface : 3. LAN
    • Address space : Otomatis sama seperti nomor 5
    • Gateway : Sama
    • Addresses : 10.10.10.2-10.10.10.254, Sesuaikan dengan addreses di atas. Konfigurasi ini bisa kita temukan di IP => POOL
    • DNS : Otomatis
    • Lease Time : Batas penggunaan alamat IP, Kita isi 00:20:00 Artinya ketika user tidak login selama 20 Menit maka IP akan di hapus.
    • NEXT
    • Lakukan hal serupa pada port lan yang lain
  9. Reboot Mikrotik dan mikrotik sudah konek ke internet
  10. System => SNTP Client : Mengatur Jam dan Tanggal di Mikrotik otomatis lewat Internet
    • Check list pada Enable
    • Server DNS : asia.pool.ntp.org
    • Primary NTP Server : 202.65.114.202
    • Secondary NTP Server : 212.26.18.41
  11. System => Clock : Mengatur waktu sesuai NTP Server diatas
    • Time Zone : Asia/Jakarta
  12. IP => Hotspot => Server : Mengatur port LAN untuk Hotspot. Client yang melalui port LAN ini memerlukan login terlebih dahulu. Hanya untuk port LAN 3 dan 4 yang kami atur.
    • Hotspot Setup
    • Interface : 3. IN_Santri
    • Local Address : Otomatis, Check List Masquerade
    • Address Pool Network : 10.10.10.xx – 10.10.10.254. Ubah xx menjadi awalan alamat IP. disini kita mulai alamat IP mulai dari 20. karena dari 2 sampai 19 kita gunakan untuk akses point. Konfigurasi ini bisa kita temukan di IP => POOL
    • Select Certificate : None
    • IP Address SNTP Server : Biarkan
    • DNS Server : Sesuai dengan yang tadi di atur
    • DNS Name : Domain untuk login Hotspot. Kita menggunakan i.net
    • Buat User dan Password Admin Login
    • Selesai. Setting ini cukup dilakukan satu kali
  13. IP => Hotspot => Server : Buka Hotspot server yang kita buat tadi.
    • Addresses per MAC : 1
    • Address Pool : Merupakan rentang alamat IP yang akan kita gunakan untuk Hotspot. Ini bisa di atur di IP => POOL
    • Profile : Kita gunakan profile default
  14. IP => Hotspot => Server Profiles : Hapus Server Profile lain. Sisakan Server Profile Default supaya lebih ringkas. Buka Server Profile Default
    • General
    • DNS Name : Domain untuk login
    • HTML Directory : Untuk memilih Template Login Hotspot
    • Login
    • Login By : Check List pada HTTP CHAP (login user password), HTTP PAP (Login user password), MAC Cookie (Auto Login bagi user yang pindah SSID Wifi.
    • OK
  15. IP => Hotspot => User Profile : Profil pengguna internet.
    • Shared User : Satu akun wifi bisa di gunakan untuk berapa perangkat
    • Rate Limit : Pembatas Kecepatan : Standar yang kami gunakan adalah 5M/5M untuk user dan 10M/10M Untuk PC
    • Untuk membuat User Profile untuk User berbatas waktu, bisa melalui MIKHMON
  16. Setting dasar Mikrotik sudah selesai

KONFIGURASI LANJUTAN MIKROTIK

  • Membuat User Profile : IP => Hotspot => User Profile .
    User profile merupakan pengelompokan user berdasarkan kategori tertentu. Kecepatan internet dan Jumlah perangkat login bersamaan. Kita juga menyisipkan mark packet di user untuk kita batasi di queue tree.
    1. Bypass:
      • Shared users : 5
      • Rate Limit : 100M/100M
        Profile ini menampung 1 User Bypass. User ini hanya di gunakan ketika ada acara streaming supaya mendapatkan koneksi lancar.
      • Incoming Packet Mark : bypassup
      • Outgoing Packet Mark: bypassdown
    2. Member:
      • Shared users : 2
      • Rate Limit : Kosongkan, karena rate limit akan kita atur pada script
      • Profile ini menampung user umum. Semua user wifi dimasukan di profile ini. Bisa di login di 2 perangkat secara bersamaan namun kecepatan akan dibagi 2. untuk itu kita perlu menambahkan script pada on login dan on logout. Script akan ditulis di bawah.
      • Incoming Packet Mark : memberup
      • Outgoing Packet Mark: memberdown
    3. PC:
      • Shared users : 1
      • Rate Limit : 5M/5M
      • Profile ini menampung komputer di pesantren. Seperti IN_Santri 1 (in1), IN_Santri 2 (in2), PSB (psb), Perpustakaan (perpus), Poskestren (poskestren)
      • Saat membuat user dengan profile ini, pastikan MAC Address diisi sesuai perangkat yang di gunakan. mencegah supaya user ini dipakai oleh orang lain.
      • Incoming Packet Mark : pcup
      • Outgoing Packet Mark: pcdown
    4. Ndalem:
      • Shared users : 10
      • Rate Limit : 1M/3M
      • Profile ini menampung 1 user untuk ahlulbait
      • Incoming Packet Mark : ndalemup
      • Outgoing Packet Mark: ndalemdown
    5. Tamu:
      • Shared users : 99
      • Rate Limit : 1M/3M
      • Profile ini menampung 1 user bebas untuk tamu apabila ada tamu di pesantren. User pada profile ini selalu disable dan hanya diaktifkan apabila ada keperluan.
      • Incoming Packet Mark : tamuup
      • Outgoing Packet Mark: tamudown
    6. Dept IT:
      • Shared users : 4
      • Rate Limit : 20M/20M
      • Profile ini menampung 1 user teknisi. Digunakan ketika ada keperluan konfigurasi jaringan
      • Incoming Packet Mark : ictup
      • Outgoing Packet Mark: ictdown
    7. 10-Jam:
      • Shared users : 1
      • Rate Limit : 1M/3M
      • Profile ini menampung voucher wifi dengan masa aktif 10 jam. Untuk konfigurasi lebih lanjut melalui aplikasi mikhmon
      • Incoming Packet Mark : vcup
      • Outgoing Packet Mark: vcdown
    8. 30-Hari:
      • Shared users : 1
      • Rate Limit : 1M/3M
      • Profile ini menampung user wifi yang hanya sekali membuat akun dan tidak berlangganan. Mirip dengan user profile member, hanya saja cuma bisa dilogin pada 1 perangkat. Untuk konfigurasi lebih lanjut melalui aplikasi mikhmon
      • Incoming Packet Mark : vcup
      • Outgoing Packet Mark: vcdown
    9. 0isolir
      • Hanya untuk tampat user yang di isolir dan yang tidak tercantum dalam pembayaran bulanan
      • Sahred user : 1
      • Rate Limit : 1M/1M
      • Incoming Packet Mark : isolirup
      • Outgoing Packet Mark: isolirdown
Script Pada User  Profile Member

On Login:
:global MaxLimitDown "3000"
:global MaxLimitUp "1000"
:local nama $user
/queue simple remove [/queue simple find name~"$nama"]
:local total [/ip hotspot active print count-only where user=$nama]
:if ($total =0) do={
:local LimitDOWN ($MaxLimitDown / $total)
:local LimitUP ($MaxLimitUp / $total)
/queue simple add name=$address target=$address max-limit=($LimitUP."k/".$LimitDOWN."k") comment=$nama place-before="MEMBER" parent="MEMBER";
:foreach i in=[/queue simple find comment =$nama] do={/queue simple set $i max-limit=($LimitUP."k/".$LimitDOWN."k")}
}\
else={
:local LimitDOWN ($MaxLimitDown / $total)
:local LimitUP ($MaxLimitUp / $total)
/queue simple add name=$address target=$address max-limit=($LimitUP."k/".$LimitDOWN."k") comment=$nama parent="MEMBER";
:foreach i in=[/queue simple find comment =$nama] do={/queue simple set $i max-limit=($LimitUP."k/".$LimitDOWN."k")}
}

On Logout:
:local nama $user;
/queue simple remove [/queue simple find name =$address]
:local total [/ip hotspot active print count-only where user=$nama]
:if ($total=0) do={
:log info "All are Devices Logout ??"
}\
else={
:local LimitDOWN ($MaxLimitDown / $total)
:local LimitUP ($MaxLimitUp / $total)
:foreach i in=[/queue simple find comment =$nama] do={/queue simple set $i max-limit=($LimitUP."k/".$LimitDOWN."k")}
}
  • Membuat User Login : IP => Hotspot => User
    Pembuatan user cukup memasukan username, password, dan jenis profile. Untuk pilihan servernya kita menggunakan All. Akan tetapi ada beberapa user yang perlu tambahan konfigurasi
    • User pada profile PC
      • Tambahkan MAC Address, supaya user terkunci pada mac address komputer dan tidak digunakan orang lain.
    • User Koperasi
      • User ini masuk ke User Profile Tamu. Akan aktif dan mati pada waktu yang telah ditentukan pada shedule. Menyesuaikan pada waktu buka tutup koperasi.
      • User ini cuma bisa dilogin pada server2. Yaitu akses point koperasi yang masuk pada port lan 4.
  • IP Binding : IP => Hotspot => IP Binding.
    Konfigurasi ini supaya akses point dan perangkat tambahan jaringan bisa di akses tanpa terhalang login page. Cukup tuliskan alamat ip dari akses point maupun cctv yang akan di binding kemudian pada type ubah menjadi bypassed
  • Login Page : IP => Hotspot => Server Profile => default
    Pada HTML Directory, tentukan lokasi folder yang mengandung login page. Ini bisa kita temukan di menu Files
    Pada DNS Name, isikan i.net. ini berati ketika kita ketikan i.net maka akan masuk ke login page mikrotik
  • Konfigurasi VPN pada Mikrotik. (Jika Berhasil)
    Salah satu fungsi VPN disini adalah mempercepat koneksi internet. Selain itu ada juga VPN Remote untuk mengakses mikrotik diluar jaringan lokal. Protokol yang kami gunakan adalah L2TP. Untuk mengkonfigurasikan tinggal memasukan HOST, USER, dan PASSWORD. Mungkin ada beberapa yang memerlukan IPsec Secret.
    1. PPP : Merupakan tempat konfigurasi VPN. Prioritas VPN Tunnel yang kami gunakan berurutan dari A ke bawah. Hanya satu VPN Tunnel yang boleh di aktifkan. VPN lain harus di disable. Apabila ada 2 atau lebih VPN tunnel aktif bersamaan maka akan ada tabrakan data dan jaringan tidak stabil
      • A. RACE VPN (www.racevpn.com). Masa aktif 5 hari, lumayan stabil.
      • B. LIST VPN (www.listvpn.net). Masa aktif 3 hari, lumayan stabil hanya saja masa aktif singkat
      • C. PPTP VPN (pptpvpn.net). Masa aktif 5 hari, lumayan stabil hanya saja di blacklist dari beberapa situs
      • D. HIDE SSH (hidessh.com). Masa aktif ada yang 7 hari. Pada VPN ini perlu memasukan IPsec Secret. Hasil tidak stabil tapi lumayan untuk alternatif apabila VPN A, B, C mengalami server down.
      • E. ELITE TUNNEL (elitetunnel.com). Kadang stabil, kadang tidak. VPN di sini berbayar murah. Alternatif apabila keempat VPN sebelumnya gagal di aktifkan.
      • F. OTHER VPN : VPN lain sebagai alternatif lain
      • VPN REMOTE : Untuk mengakses mikrotik dari luar jaringan. Kami menggunakan remote.vpnmurahjogja.my.id yang kami dapatkan gratis dari bot telegram
    2. IP => Firewall => NAT : Penerus VPN. Kita buat 6 NAT sesuai dengan jumlah VPN Tunnel. NAT ini akan aktif apabila VPN aktif. Jadi jangan aktifkan VPN Tunnel secara bersamaan supaya tidak ada tabrakan data.
      • Tombol PLUS
      • General
      • Chain : srcnat
      • Out. Interface : A. RACE VPN (pilih interface VPN)
      • Action
      • Action : Masquerade
      • OK
    3. IP => Firewall => Mangle : Penanda paket VPN. Disini paket yang akan kita tandai ada di IP Address dari port LAN. Misalkan port LAN Hotspot IN_Santri adalah 10.10.10.xx. maka ip nya adalah 10.10.0.0/16
      • Tombol PLUS
      • Chain : prerouting
      • Src. Address : 10.10.0.0/16
      • Dst. Address : ! 10.10.0.0/16 (kita checklist Dst. Address supaya data tidak terbaca di Port LAN ISP
      • Action
      • Action : mark routing
      • New Routing Mark : VPNXmark (terserah, ini merupakan penanda paket. Akan kita beri nama apa paket ini)
      • OK
      • Lakukan hal serupa pada port LAN yang lain
    4. IP => ROUTES : Untuk mengalihkan data menuju VPN Tunnel. Seperti NAT tadi, kita perlu membuat 6 routes sesuai dengan jumlah VPN Tunnel. Routes ini akan aktif apabila VPN aktif. Jadi jangan aktifkan VPN Tunnel secara bersamaan supaya tidak ada tabrakan data.
      • Sebelumnya perlu mengubah Distance dari ISP menjadi 2. Kita pergi ke IP => DHCP Client : klik di Interface ISP. Pada tab Advance, ganti Default Route Distance menjadi 2. kemudian OK
      • Kembali lagi ke IP => ROUTES
      • Tombol PLUS
      • Gateway : pilih Interface VPN (Misalkan A. RACE VPN)
      • Routing Mark : pilih routing mark yang dibuat di Mangle tadi. (VPNXmark)
      • OK
  • Tambahkan Server Email : Tools => Email
    Konfigurasikan ini untuk menentukan server email di mikrotik. Jadi kita bisa mengirimkan file backup mikrotik ke email kita. Konfigurasi backup otomatis ke email akan di bahas pada bagian shedule.
    • Server : 173.194.77.108
    • Port : 587
    • Start TLS : yes
    • From : <>
    • User : in.santri.ku@gmail.com
    • Password : (isi dengan password email)
  • Perintah yang di jalankan otomatis di mikrotik sesuai jadwal : System => Sheduler
    Konfigurasi membuat penjadwalan Mikrotik yang berjalan sesuai jangka waktu tertentu.
    • Delete hs : Menghapus simple queue pada server hotspot. berjalan setiap satu menit.
      • /queue simple remove [find name=hs-<hotspot>]
      • /queue simple remove [find name=hs-<server2>]
    • Remove Active User : Mengeluarkan semua user yang masih login pada jam 04:00 pagi dan Menghapus MAC Cookies pengguna hotspot. Supaya pengguna tidak auto login dan diharuskan login sehari satu kali. Shedule ini berjalan satu hari sekali pada jam 04:00
      • /ip hotspot active remove [find user=$user]
      • /ip hotspot cookie remove [find user=$user]
    • Backup Mikrotik Tiap Hari : Otomatis Backup Konfigurasi Mikrotik dan User Mikrotik tiap jam 04:30 Pagi. File backup otomatis dikirimkan ke alamat email kami. Shedule ini berjalan satu hari sekali pada jam 04:30
      • /system backup save name=backupfull
      • /ip hotspot user export file=backupuser
      • /tool e-mail send to=”in.santri.ku@gmail.com” subject=”MIKROTIK” body=”Backup Full” file=”backupfull” start-tls=yes
      • /tool e-mail send to=”in.santri.ku@gmail.com” subject=”MIKROTIK” body=”User Backup” file=”backupuser” start-tls=yes
    • VPN DOWN : Apabila vpn down maka akan mengirimkan pesan otomatis berulang ke telegram monitoring jaringan. Script berjalan tiap satu menit
      • :if ([/ping 1xx.xx.0.1 count=5] =0) do {/tool fetch url=”https://api.telegram.org/bot1821336xx_TOKEN_API_BOT_TELEGRAM_xx2j2Blss/sendMessage?chat_id=-5x_ID_CHAT_GRUP_x47&text=X PERINGATAN!— VPN DOWN – Pindahkan Interface Segera!—” keep-result=no }
        • 1xx.xx.0.1 : IP dari VPN pada interface utama, yaitu A, B, dan C.
        • 1821336xx_TOKEN_API_BOT_TELEGRAM_xx2j2Blss : Token API dari BOT Telegram @santrinet
        • -5x_ID_CHAT_GRUP_x47 : ID Chat dari grup Telegram Monitoring Jaringan IN_Santri
    • ON Koperasi : Menghidupkan user koperasi pada jam 07:00, 12:30, dan 21:00
      • /ip hotspot user enable [find name=koperasi]
    • OFF Koperasi : Mematikan user koperasi dan logout pada jam 12:00, 15:00, dan 23:00
      • /ip hotspot user disable [find name=koperasi]
      • /ip hotspot active remove [find user=koperasi]
  • Queue => Queue Tree : Merupakan konfigurasi pembatas kecepatan universal. Kita menandai paket data download supaya kecepatannya tidak overload. Ada Pembatas kecepatan melalui Mark Packet di User Profile yang sudah kita buat diatas. Namun sebelumnya kita perlu mengatur penerus packet pada NAT.
    • IP => Firewall => NAT
    • Tombol PLUS
    • Chain : srcnat
    • Src. Address : Isi dengan alamat ip interface yang akan kita batasi kecepatannya. disini ada 10.10.10.0/24 yaitu port 3. Buat juga NAT untuk port lan 4 dan 2.
    • Action
    • Action : Masquerade
    • OK

    • Sekarang membuat penanda menggunakan User Profile. Buka pada IP => Hotspot => User Profiles. Kita buka profile yang akan kita batasi secara spesifik. Pada kasus ini kami memberikan packet mark pada user member. Sudah dibahas pada bagian membuat user profile di atas.
    • Buka Profile Member
    • General
    • Incoming Packet Mark : memberup (Packet upload)
    • Outgoing Packet Mark : memberdown (Packet download)
    • OK

      Langkah terakhir adalah membuat pembatas kecepatan pada queue tree. Buka Queue => Queue Tree.
    • Tombol PLUS
    • Name : Download (Sebagai parent queue)
    • OK
    • Tombol PLUS
    • Name : Member
    • Parent : Download
    • Packet Marks : memberdown ; Ini adalah packet mark yang kita buat di user profile tadi.
    • Max Limit : bisa di kosongkan saja. ini akan kita isi apabila ada keharusan mendapatkan full speed pada akun bypass.
    • OK
      Buat lagi Queue tree seperti di atas untuk semua user. Untuk penggunaannya, ketika kita membutuhkan kecepatan tinggi pada user bypass, kita tinggal mengatur pembatas kecepatan Max Limit pada queue yang lain.
    • Informasi packet mark dapat di lihat di bagian user profile diatas
  • Menambahkan Netwatch : Tools => Netwatch
    Mengirim pesan ke grup telegram monitoring jaringan apabila ada akses point yang tidak berfungsi. Disini kita memerlukan id chat pada grup kita dan port api pada Bot telegram yang digunakan untuk mengirim pesan. Cara settingnya hampir mirip dengan IP Binding tadi.
    • Tombol PLUS
    • Isikan IP Akses Point, CCTV, DVR, maupun perangkat lain yang akan di monitor
    • Pada tab Up, isikan script pesan otomatis ke grup telegram monitoring jaringan.
      /tool fetch url=”https://api.telegram.org/bot1821336xx_TOKEN_API_BOT_TELEGRAM_xx2j2Blss/sendMessage?chat_id=-5x_ID_CHAT_GRUP_x47&text=ONLINE – AP LOKASI – 10.10.10.IP” keep-result=no
    • Pada tab Down, isikan juga script pesan otomatis ke grup telegram monitoring jaringan.
      /tool fetch url=”https://api.telegram.org/bot1821336xx_TOKEN_API_BOT_TELEGRAM_xx2j2Blss/sendMessage?chat_id=-5x_ID_CHAT_GRUP_x47&text=DOWN – AP LOKASI – 10.10.10.IP” keep-result=no
    • OK
      Maka ketika akses point mati atau kabel putus sehingga akses internet dari mikrotik tidak sampai ke akses point, Netwatch akan mengirimkan pemberitahuan ke Grup Telegram bahwa aksespoint down sehingga mudah di atasi oleh teknisi.
  • Kita menggunakan loadbalance 2 jalur jaringan. script bisa di sesuaikan di sini https://buananetpbun.github.io/pcc.html
  • Kelompokan interface wan dan lan
    • Interface list – tambahkan list. beri nama lan dan wan
    • klik tombol plus, kelompokan lan dan wan
  • /ip firewall nat (ini sudah di lakukan di awal, bisa di lewati)
    • add chain=srcnat out-interface=”eth 1 ISP IN_Santri” action=masquerade comment=”LB By BNT”
    • add chain=srcnat out-interface=”eth 2 ISP Koperasi” action=masquerade comment=”LB By BNT”
  • /ip route
    • add check-gateway=ping distance=1 gateway=”192.168.1.1” routing-mark=”to-eth 1 ISP IN_Santri” comment=”LB By BNT”
    • add check-gateway=ping distance=1 gateway=”192.168.2.2” routing-mark=”to-eth 2 ISP Koperasi” comment=”LB By BNT”
    • add check-gateway=ping distance=1 gateway=”192.168.1.1” comment=”LB By BNT”
    • add check-gateway=ping distance=2 gateway=”192.168.2.2” comment=”LB By BNT”
  • /ip firewall mangle
    • add action=mark-connection chain=input in-interface=”eth 1 ISP IN_Santri” new-connection-mark=”cm-eth 1 ISP IN_Santri” passthrough=yes comment=”LB By BNT”
    • add action=mark-connection chain=input in-interface=”eth 2 ISP Koperasi” new-connection-mark=”cm-eth 2 ISP Koperasi” passthrough=yes comment=”LB By BNT”
    • add action=mark-routing chain=output connection-mark=”cm-eth 1 ISP IN_Santri” new-routing-mark=”to-eth 1 ISP IN_Santri” passthrough=yes comment=”LB By BNT”
    • add action=mark-routing chain=output connection-mark=”cm-eth 2 ISP Koperasi” new-routing-mark=”to-eth 2 ISP Koperasi” passthrough=yes comment=”LB By BNT”
    • add action=mark-connection chain=prerouting dst-address-list=!LOCAL-IP dst-address-type=!local new-connection-mark=”cm-eth 1 ISP IN_Santri” passthrough=yes per-connection-classifier=both-addresses-and-ports:2/0 src-address-list=LOCAL-IP comment=”LB By BNT”
    • add action=mark-connection chain=prerouting dst-address-list=!LOCAL-IP dst-address-type=!local new-connection-mark=”cm-eth 2 ISP Koperasi” passthrough=yes per-connection-classifier=both-addresses-and-ports:2/1 src-address-list=LOCAL-IP comment=”LB By BNT”
    • add action=mark-routing chain=prerouting connection-mark=”cm-eth 1 ISP IN_Santri” dst-address-list=!LOCAL-IP new-routing-mark=”to-eth 1 ISP IN_Santri” passthrough=yes src-address-list=LOCAL-IP comment=”LB By BNT”
    • add action=mark-routing chain=prerouting connection-mark=”cm-eth 2 ISP Koperasi” dst-address-list=!LOCAL-IP new-routing-mark=”to-eth 2 ISP Koperasi” passthrough=yes src-address-list=LOCAL-IP comment=”LB By BNT”
  • /ip firewall mangle (konfig asli)
    • add action=mark-connection chain=prerouting comment=lbpcc connection-mark=\ no-mark hotspot=auth in-interface=”eth 1. ISP IN_Santri” \ new-connection-mark=CM-WAN1 passthrough=yes
    • add action=mark-connection chain=prerouting comment=lbpcc connection-mark=\ no-mark hotspot=auth in-interface=”eth 5. ISP Koperasi” \ new-connection-mark=CM-WAN2 passthrough=yes
    • add action=accept chain=prerouting comment=lbpcc-wan1 dst-address=\ 192.168.2.0/24 hotspot=auth in-interface-list=LAN
    • add action=accept chain=prerouting comment=lbpcc-wan2 dst-address=\ 192.168.1.0/24 hotspot=auth in-interface-list=LAN
    • add action=mark-connection chain=prerouting comment=lbpcc connection-mark=\ no-mark dst-address-type=!local hotspot=auth in-interface-list=LAN \ new-connection-mark=CM-WAN1 passthrough=yes per-connection-classifier=\ both-addresses-and-ports:2/0
    • add action=mark-connection chain=prerouting comment=lbpcc connection-mark=\ no-mark dst-address-type=!local hotspot=auth in-interface-list=LAN \ new-connection-mark=CM-WAN2 passthrough=yes per-connection-classifier=\ both-addresses-and-ports:2/1
    • add action=mark-routing chain=prerouting comment=lbpcc connection-mark=\ CM-WAN1 hotspot=auth in-interface-list=LAN new-routing-mark=RM-WAN1 \ passthrough=yes
    • add action=mark-routing chain=prerouting comment=lbpcc connection-mark=\ CM-WAN2 hotspot=auth in-interface-list=LAN new-routing-mark=RM-WAN2 \ passthrough=yes
    • add action=mark-routing chain=output comment=lbpcc connection-mark=CM-WAN1 \ hotspot=auth new-routing-mark=RM-WAN1 passthrough=yes
    • add action=mark-routing chain=output comment=lbpcc connection-mark=CM-WAN2 \ hotspot=auth new-routing-mark=RM-WAN2 passthrough=yes

TOPOLOGI JARINGAN

KONFIGURASI MIKHMON (Mikrotik Hotspot Monitor)

Mikhmon merupakan aplikasi dengan menggunakan port API untuk mengakses mikrotik. Berfungsi seperti halnya Winbox, hanya saja lebih simple dan mudah dikelola.

Catatan dalam Pemasangan Jaringan

  • Panjang kabel LAN untuk memasang akses point tidak boleh lebih dari 50Meter. Dihawatirkan akan terjadi Packet Lost
  • Urutan warna dalam pemasangan kabel LAN menggunakan formasi Straight. Hanya saja kabel lan HUB PSB ke AP Sambang Putra menggunakan urutan berbeda karena kesalahan dalam pemasangan konektor rj45 sehingga kabel tertukar.
  • Pada area terbuka yang terkena air, tidak di perbolehkan menyambung kabel LAN menggunakan barrel connector RJ45 karena akan berkarat. Langsung sambung saja antara kabel dengan kabel.
  • Jalur LAN biasa hanya dipakai 4 kabel, yaitu putih orange, orange, putih hijau, hijau. Isi kabel setiap kabel LAN ada 8 kabel. Jadi ada beberapa kabel lan yang dilalui 2 data. yaitu dari HUB PSB ke lt2 SMK. Pada lantai 2 SMK kabel orange dan hijau menuju ke HUB IN_Santri, dan kabel biru coklat menuju AP Kantor Elekrtonik Putra.
  • Ada beberapa jalur kabel LAN yang dilalui listrik dari adaptor POE (power over ethernet). Ada yang asli maupun modif manual. Karena akses point tidak selalu berada di dekat sumber listrik, maka kami memodifikasi kabel untuk POE.

    • Jalur LAN yang memiliki POE Asli:
    • HUB PSB ke AP Sambang Putra
    • HUB IN_Santri ke AP LT3 Selatan
    • AP LT3 Selatan ke AP LT3 Utara (POE kami ambil dari tengah, bukan full)
    • HUB IN_Santri ke AP Depan IN_Santri

    • Sedangkan Jalur LAN yang memiliki POE Modifan:
    • AP Klinik ke AP Aula Utama (sambungan di stopkontak terdekat)
    • HUB Lorong Koperasi ke AP Mading
    • HUB Perpustakaan ke AP Perpustakaan
    • Stopkontak Kantor HP Putra ke AP Kantor Elektronik
    • Stopkontak Kantor HP Putra ke AP F40
  • Iuran untuk tiap penguna internet adalah Rp10.000 per bulan dibayarkan tiap bulan sekali. Apabila akhir bulan tercatat belum membayar maka akun internet akan di isolir dengan mengganti limit uptime pada user hotspot menjadi 00:00:01. Maka akan gagal login dan dialihkan ke halaman expired ketika akun tersebut login. Juga ganti user profile menjadi 0isolir
  • Setiap minggu ke 2, 3, dan 4, kita harus renew fup dengan total 140 tiap renew.
  • Apabila dalam penggunaan bulanan kurang dari 5GB (dalam catatan mikrotik), maka user tersebut tidak diwajibkan membayar penggunaan pada bulan itu dan dibebaskan dari isolir.
  • Apabila akan di padukan dengan proyek CCTV, gunakan CCTV dengan fitur LAN, bukan Coaxial. Juga gunakanlah DVR yang sudah support input ip camera. sehingga dapat dipasang dimanapun dengan mudah